当前位置: 西部量化>指标下载>博弈大师指标

变色MACD

运行平台:博弈大师更新时间:2015-07-30授权方式:免费文件大小:0.67KB

变色MACD

DIFF:(EMA(CLOSE,12) - EMA(CLOSE,26))*20,COLORFFFFFF,LINETHICK1;
DEA:EMA(DIFF,9),COLOR00FFFF,LINETHICK1;
MACD:2*(DIFF-DEA), COLORSTICK;
MACD1:2*(DIFF-DEA),COLORRED,LINETHICK0;
MACD2:SMA(MACD1,0,3),COLORFFFF00,LINETHICK0;
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,2,0),COLORRED;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,2,0),COLOR00FFFF;
STICKLINE(MACD1<MACD2,0,MACD1,1,0),COLOR40FF00;
S1:=MACD<0;
S2:= (MACD>=0);
S3:=BARSLAST(CROSS(DIFF,DEA));
S4:=REF(S3,S3+1);
S5:=DEA>REF(DEA,S4);
S6:=DEA;
上成立:=CROSS(DIFF,DEA) AND S5;
下成立:=CROSS(DIFF,DEA) AND S6;
L1:=(EMA(CLOSE,3) - EMA(CLOSE,13));
L2:=EMA(L1,9);
L3:=BARSLAST(CROSS(L1,L2));
L4:=REF(L3,L3+1);
L5:=L2;
变盘:CROSS(L1,L2) AND L5,LINETHICK0,COLORD6FF9C;
STICKLINE(变盘,5,-5,4,1),COLORD6FF9C;
成立距今:BARSLAST(CROSS(DIFF,DEA)),LINETHICK0;
L6:=BARSCOUNT(CLOSE);
DRAWTEXT(CROSS(L1,L2),DIFF,'买'),COLOR0000FF;
DRAWTEXT(CROSS(L2,L1),DIFF,'卖'),COLORFFFF00;
REF(DEA,S3),POINTDOT,COLORGREEN;
IF(L1>L2,REF(DEA,S3),0),POINTDOT,LINETHICK5,COLORB078FF;
IF(MACD<0,REF(DEA,S3),0),POINTDOT,LINETHICK5,COLORGREEN;
LS:=IF(DIFF>DEA AND DIFF>0,1,0);
加速上扬:IF(REF(LS=0,1) AND LS=1,0.1,0);
XG1:CROSS(MACD1,MACD2) AND MACD1<0,LINETHICK0;
XG2:CROSS(DIFF,DEA),LINETHICK0;
M1:=MACD>REF(MACD,1) AND DIFF<DEA;
绿柱短了:M1 AND COUNT(M1,10)=1 AND C>MA(C,55) AND COUNT(MACD<0,5)>=5,LINETHICK0;
DRAWTEXT(绿柱短了,MACD,'绿柱短了'),COLOR00FF80;

如果您对编写期货指标有兴趣,可以联系西部量化网在线客服或查看TB量化编程文华量化编程
以上文章、数据及文件仅供参考,使用前请核实,风险自负。

多空参考

多空参考期货指标-博易大师指标,多空参考,即在...

顶底王

顶底王期货指标-博易大师指标公式源码,判断期货...

波段中心

波段中心...

t-trad

t-trad...
版权所有@西部量化网热线电话:029-89576768    18966736851在线客服沪ICP备12043003号-2